Get in touch
Back
Maintenance

BedWars datalose

Started 28 Feb at 01:00am CET.

BedWars
Updated

The datas are gone forever! We are now recreating BedWars with old Backups and working on BedWars V3. Your stats could be rolled back.

Posted .
Updated

Our host had some problems while migrating data and lost data. On 7GAMES, BedWars is affected. We are currently working on getting the data back. At the moment we don't know if the data can be recovered or if it is lost forever.

Posted .
Started

The datas are gone forever! We are now recreating BedWars with old Backups and working on BedWars V3. Your stats could be rolled back.

Posted 28 Feb at 01:00am CET.